or Connect
Cycling Forums › Forums › Bikes › Power Training › PT SL2.4 Problems
New Posts  All Forums:Forum Nav:

PT SL2.4 Problems

post #1 of 52
Thread Starter 
According to the earlier poll, there are at least 20 PT SL2.4 owners on the forum. I'd be interested in any details these members can provide as to problems with the hub or computer. Please be as specific as possible as to the nature of the problem, the diagnosis and fix (if it's fixed) and your thoughts on the reliability of the unit. I ask because I'm about to put in a group order on PTs for my racing team and a bunch of the guys are considering the SL2.4. If I say it looks solid and they end up with problems, I'll probably have to relocate to, say, Australia.
post #2 of 52

Re: PT SL2.4 Problems

I've had the PT SL 2.4 for about three weeks now. I've had two problems.

1. The original CPU I received would not pick up the HR signal 85+% of the time. Replacement of the CPU fixed this. Now, the only time I lose the HR is if I stop for a few minutes, the 2.4 does not seem to automatically re-pick up the HR. I have to hold the two buttons until "find" appears and it will re-acquire the HR signal.

2. When I first receive the unit it dropped the hub signal on a regular basis. The drops usually lasted for only a second or two, but I might have upwards of 100 such drops on a long ride. The incidence of these drops seems to have decreased with the new CPU. For example, I only had 5 or so drops on a two hour indoor trainer ride. Outside, I still had about 20 drops over about three hours. I am waiting for the weeked the re-test its performance outside.

I have emailed Saris to see if such drops are "normal" or if there is a way to correct them short of sending the hub back. Since the drops are so short, I do not lose data. I just want to be sure that my unit is working as it should for $1400.
post #3 of 52

Re: PT SL2.4 Problems

That's real funny, Rapdadyo, like when you said you hate rap too. Always thought you liked it because it was your name. I hate rap and hip hop too.
post #4 of 52

Re: PT SL2.4 Problems

Quote:
Originally Posted by gogoturtle
...Since the drops are so short, I do not lose data...
100 drops in a ride? That sounds like 1.5 minutes of lost data to me - depending on when it happens it could definitely affect your overall data (my PT SL with the older sensor used to drop out at the top of sprints, which would definitely skew 5s and 10s power.)

@RDO - Given Saris' track record of 'rolling improvements' you're a brave man to do an early-adopter group buy. The weather is nice in Australia, though.
IMO, it took Saris until just six months ago to make the PT SL truly robust with the shark fin sensor and the 'dipped' circuits. How long had it been on the market?
post #5 of 52

Re: PT SL2.4 Problems

Had mine for 3 weeks now. No problems except for one ride where HR wasn't recorded after I stopped 2.5 hrs into ride and started off again 2min later.

I've been doing rides mostly on indoor trainer but any rides outside have been 100% (excpet for above example).
post #6 of 52

Re: PT SL2.4 Problems

I just heard from Saris.

They said that they are having dropping issues with a very small number of units. I am going to ship this back and the turnaround should be only a day or two. Apparently, fixing these is their number one priority.
post #7 of 52

Re: PT SL2.4 Problems

Quote:
Originally Posted by gogoturtle
I just heard from Saris.

They said that they are having dropping issues with a very small number of units. I am going to ship this back and the turnaround should be only a day or two. Apparently, fixing these is their number one priority.
I would assume and hope they test these things before they ship them out. For $1495, I would not tolerate recurrent drop out of hub or HR data. It is encouraging they are aggressively fixing them (post marketing).
post #8 of 52

Re: PT SL2.4 Problems

I've had mine for two weeks now. No problems other than after a slow flat change on a group ride the unit didn't immediately regain transmission lock after falling asleep and having me wake it up with a button push. I lost about 4 minutes of data. It could have been operator error since that was only my third or fourth ride with it.
post #9 of 52

Re: PT SL2.4 Problems

I've had my 2.4 for about 25 days, and ridden about 21 of them. When I got unit, it said low battery on CPU - so I replaced it. I ride on avg only a little more than an hour to 1.5 hours per day. I got another low battery reading today.... so will replace it again... Don't know if battery typically dies after 30+ hours... but seems like a lot of battery replacing!
post #10 of 52
Thread Starter 

Re: PT SL2.4 Problems

Quote:
Originally Posted by gogoturtle
I just heard from Saris.

They said that they are having dropping issues with a very small number of units. I am going to ship this back and the turnaround should be only a day or two. Apparently, fixing these is their number one priority.
I am following your experience closely, gogoturtle. Thanks for sharing. BTW, is Saris paying for the shipping expense both ways? Based on what I have seen thus far, I am thinking I will go one of two ways. One is to specifically advise against the SL2.4 at this time due to teething issues (but, if someone wants to go ahead and take a chance, fine). Two is to negotiate with Saris in advance that they pay express shipping both ways for any hub or cpu problems that require return of the unit(s). The only thing worse than paying out $1K plus for a product that doesn't work as advertised is paying out an additional $50 for the pleasure of getting one that works.
post #11 of 52

Re: PT SL2.4 Problems

Quote:
Originally Posted by dlinenbe
Don't know if battery typically dies after 30+ hours
Sounds like the original Tune CPU!
post #12 of 52

Re: PT SL2.4 Problems

Quote:
Originally Posted by RapDaddyo
BTW, is Saris paying for the shipping expense both ways?
Yes, they are going to email me a shipping label (UPS ground). So, I can send it back to them at no cost to me. If they turn it around in a day or two from when they receive it, I should have it back within two weeks.
post #13 of 52

Re: PT SL2.4 Problems

FWIW, Saris customer service is seemingly swamped right now. I wanted to contact them about something besides a power tap. On Monday, I got continuous busy signals when I called. On Tuesday, the customer service line just rang and rang and no one picked up so I sent an e-mail. Still haven't gotten a reply (other than the auto reply).

This is unlike the other 5 or 6 times in the past 3 or so years that I have contacted them.

Just mentioning this. Not sure if it's related to the release of the 2.4 or what.
post #14 of 52

Re: PT SL2.4 Problems

Quote:
Originally Posted by RapDaddyo
I am following your experience closely, gogoturtle. Thanks for sharing. BTW, is Saris paying for the shipping expense both ways? Based on what I have seen thus far, I am thinking I will go one of two ways. One is to specifically advise against the SL2.4 at this time due to teething issues (but, if someone wants to go ahead and take a chance, fine). Two is to negotiate with Saris in advance that they pay express shipping both ways for any hub or cpu problems that require return of the unit(s). The only thing worse than paying out $1K plus for a product that doesn't work as advertised is paying out an additional $50 for the pleasure of getting one that works.
RapDaddyo have you already placed your order? And how many SL2.4 will it contain?
post #15 of 52
Thread Starter 

Re: PT SL2.4 Problems

Quote:
Originally Posted by PaulMD
RapDaddyo have you already placed your order? And how many SL2.4 will it contain?
Not yet. I'm still awaiting more info on the SL2.4. Also, I want to negotiate a return policy with Saris with respect to shipping methods and costs if it becomes necessary to return a hub. I'd love to be able to determine if a hub has problems upon receipt (before building it into a wheel), but I haven't figured out how to do that.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Training
Cycling Forums › Forums › Bikes › Power Training › PT SL2.4 Problems