Bike hut travel track pump



tomtag83

New Member
Sep 15, 2013
2
0
0
I have recently bought a Bike Hut travel track pump which states its for both types of valves, I've changed the head by flipping it from Schrader to presta setting but still can't get it to work it seems to not fit correctly. Can anyone offer some advice thanks!
 

Volnix

Well-Known Member
Feb 19, 2011
2,883
281
63
Is it one of those that you un-screw the adapter and screw it on its other side back to the pump? Maybe you need to flip something from the inside of the pump too? Like an internal flange or something?
 

tomtag83

New Member
Sep 15, 2013
2
0
0
It's one were you unscrew the adapter pull out a fitting completely then flip it and re-insert them screw a cap back on???? It doesn't appear to fit at all!!!
 

CAMPYBOB

Well-Known Member
Sep 12, 2005
11,945
2,086
113
There's only a couple of things that can go wrong with a pump.

1. Is the pump functioning? Does air come out the chuck when the pump piston is cycled?

2. Is the chuck's rubber insert properly sealing that air so that it fills the tire or does it leak? You say it does not fit (the valve? The inside of the chuck?) correctly. Is the chuck too tight to go on the Presta valve or too loose?

The online reviews are fairly positive for this model, but there are reports the reversible rubber seal inside the chuck can leak or wears quickly and then does not seal. Most moderate and high quality pumps have a taper built inside the chuck head to adjust the fit of the rubber seal to the Presta valve and to compensate for wear in the rubber from being repeatedly pressed onto valve stems and removed from them. Is your model adjustable?