campy 10 - fix for bad upshift clunks?



Status
Not open for further replies.
A

Alan

Guest
Running full Campy Record 10 setup- This has been happening since the parts were new. Downshifts
under light load are very smooth, Upshifts under any load feel like the chain slips a tooth then
catches resulting in a loud "clunk". Hanger looks aligned too. Any ideas? Thanks!
 
F

Fred Roses

Guest
"alan" <[email protected]> wrote in message news:<[email protected]>...
> Running full Campy Record 10 setup- This has been happening since the parts were new. Downshifts
> under light load are very smooth, Upshifts under any load feel like the chain slips a tooth then
> catches resulting in a loud "clunk". Hanger looks aligned too. Any ideas? Thanks!

Are you by any chance using a Wipperman chain? My Campag 10 clunked loudly with a Wipperman but
shifts smoothly with a new-style Campag chain.
 
J

Jkpoulos7

Guest
>Upshifts under any load feel like the chain slips a tooth then catches resulting in a loud "clunk".
>Hanger looks aligned too. Any ideas?

Get Shimano.
 
Q

Qui Si Parla Ca

Guest
jkpoulos-<< >Any ideas?

Get Shimano.

Get out.....

Peter Chisholm Vecchio's Bicicletteria 1833 Pearl St. Boulder, CO, 80302
(303)440-3535 http://www.vecchios.com "Ruote convenzionali costruite eccezionalmente bene"
 
G

Gocycle

Guest
[email protected] (Jkpoulos7) wrote in message
news:<[email protected]>...
> >Upshifts under any load feel like the chain slips a tooth then catches resulting in a loud
> >"clunk". Hanger looks aligned too. Any ideas?
>
> Get Shimano.

Shimano breaks down!

Camy breaks in......
 
Status
Not open for further replies.