Creaking/squeaking Speedplay cleats

Discussion in 'Cycling Equipment' started by allenpg, Aug 24, 2006.

  1. allenpg

    allenpg New Member

    Joined:
    Jul 6, 2004
    Messages:
    60
    Likes Received:
    0
    I have a pair of Speedplay Zeros that continue creaking/squeaking despite my greasing the cleat bolts and using a dry lube on the cleats. I mostly get the noise under harder pedaling. I wear adidas adistar shoes and haven't had a chance to try the cleats on another pair of shoes. Any ideas? Do I have the cleats screwed too tightly against the shoes? I've had no problems getting in out of the pedals. Quite an annoying conundrum.

    Thanks for the help!
    -Pete
     
    Tags:


  2. aacliment

    aacliment New Member

    Joined:
    May 9, 2006
    Messages:
    46
    Likes Received:
    0
    Have you greased the pedals? You are supposed to do this periodically. Check the lit that came with the pedals for instructions on how to do it...the squeaking (chirping?) could also be coming from the chain. Could be a stiff link. Try cleaning the chain with a degreser and then re lube.
     
  3. allenpg

    allenpg New Member

    Joined:
    Jul 6, 2004
    Messages:
    60
    Likes Received:
    0
    I had eliminated all of the usual suspects like the bottom bracket, seatpost, chain, etc. and I knew it was the pedals (I got the noise on 2 bikes). I ended up calling Speedplay and talked to one of their techs. He recommended loosening the cleats slightly and lubing the cleat spring after 1-2 rides. Eureka! No more noise! I've really been pleased by Speedplay's service in the past. You can actually call and speak to a real person!
     
Loading...
Loading...