Does a Polar Power Output kit work with a Shimano 10 speed chain?

Discussion in 'Power Training' started by JTE83, Jun 29, 2006.

  1. JTE83

    JTE83 Member

    Joined:
    Jan 28, 2004
    Messages:
    1,390
    Likes Received:
    9
    Does a Polar Power Output kit work with a Shimano Ultegra 10 speed chain? Is it the right metal? I just got a kit from ebay and I don't get Cadence and Power readings. I think my powermeter is bad. Hopefully I'll get a return on ebay.
     
    Tags:


  2. MY02_STi

    MY02_STi New Member

    Joined:
    May 26, 2004
    Messages:
    234
    Likes Received:
    0
    Without cadence you won't get any power readings. Maybe check the magnet and positioning of the sensor unit itself. A 9 speed or 10 speed chain won't make any difference
     
  3. Woofer

    Woofer New Member

    Joined:
    Dec 31, 2004
    Messages:
    599
    Likes Received:
    0
    Unless you actually spent $300 on a Titanium chain, your chain is almost entirely made of some sort of steel which is all the chain speed sensor on your rear derailleur needs.

    The default cadence magnet from Polar is crap. Try just moving a magnet past the cadence sensor position to verify that the LED in the power thingamabob goes off.
     
  4. JTE83

    JTE83 Member

    Joined:
    Jan 28, 2004
    Messages:
    1,390
    Likes Received:
    9
    I definitely have a good working cadence magnet on. This is my 4th power kit. 2 work excellent, 1 is slightly high, and this one doesn't work.

    I glue a strong cylindrical magnet to my pedal.
     
  5. Bloggy

    Bloggy New Member

    Joined:
    Jun 12, 2006
    Messages:
    6
    Likes Received:
    0
    Have a check on this thread as I have just solved similar issues
    http://www.cyclingforums.com/t-329277-15-1.html

    As for the chain. I have the Ultegra 10sp and I have no issues with the chain being sensed at all. One other thing you should check is that ALL LED flashes are present.
    Green = cadence
    Red = speed
    Orange = Chain speed (mounted on derailier)
     
  6. jmocallaghan

    jmocallaghan New Member

    Joined:
    Dec 27, 2003
    Messages:
    137
    Likes Received:
    0
    Go to radio shack, buy a rare earth magnet ($2 about). Replace the cadence magnet from Polar with this. I put it on my crank with RTV seal. You can use tape, glue, etc, if you like as well. This will help your cadence issue.

    On the chain, polar sensors work work with any steel chain.

     
Loading...
Loading...