Garmin Edge 305 problem.



bikemonk

New Member
Jul 30, 2003
24
0
0
54
For the last couple of weeks, when I try to connect my Edge 305 to my computer to download my trainings, there is a notification saying that there is a problem between the device and my pc and that I should make sure the device is connected to the computer. The device is indeed connected (it recharges regularly) but there is no download taking place. Has anyone encountered the same problem? Any help would be appreciated.
 

bpatterson

New Member
Aug 27, 2006
71
0
0
i had a 305 for 3yrs and have upgrade to the 705 this summer ... try a new cord or reload the driver using the garmin update software
 

mjmc1273

New Member
May 25, 2003
13
0
1
bikemonk said:
For the last couple of weeks, when I try to connect my Edge 305 to my computer to download my trainings, there is a notification saying that there is a problem between the device and my pc and that I should make sure the device is connected to the computer. The device is indeed connected (it recharges regularly) but there is no download taking place. Has anyone encountered the same problem? Any help would be appreciated.

I have a Garmin 301 and had the same problem a couple monthes back. I contacted the Garmin Tech Support via email and they instructed me to reset the unit. This reset totally wipes your unit clean, but after you restore your settings it should link to your PC without a problem. Worked for me!
 

Sabalo

New Member
Sep 2, 2010
2
0
0
I had the same problem till I updated the software at the Garmin website.
 

ser0tta

New Member
Jun 28, 2011
1
0
0
I have the same issue with my edge 305. I have done a hard reset, re-installed the garmen training center on my computer & re-installed usb drivers. I have tried to use it on different computers. It states its receiving a charge but my computer doesn't recognize it.

anyone have this problem?


I'm glad I bought insurance on this item. I have had it for three years and I think its time for a new on.
 

rizz

New Member
Jun 29, 2011
20
0
0
If you are experiencing the issue on multiple computers then it's likely not drivers or software. Try another cord to rule it out. Failing that, send it in for warranty; that's what you have it.