Help! Mystery Clunk!

Discussion in 'Cycling Equipment' started by snackchair, Sep 1, 2010.

  1. snackchair

    snackchair New Member

    Joined:
    Sep 1, 2010
    Messages:
    1
    Likes Received:
    0
    Haven't ridden the TT bike in 2 months, hop on there today and there's a bizarre clunk coming from the bottom bracket. It's almost like a hitch. With the chain off the rings, sitting in place and pedaling I really feel it towards the top of the pedal stroke (1 oclock), as soon as I put pressure on it on both crank arms. It's not subtle either.

    So, I pull the crank off, clean and regrease the bottom bracket, tighten it down, along with the chainring bolts and the pedals... and it's still there. No change. The bearings in the bottom bracket seem smooth, so I didn't think it was them, but that's all I can think of. Could the bearings come loose?

    It's an FSA mega exo bottom bracket.

    Is there something I'm missing?
     
    Tags:


  2. Froze

    Froze Well-Known Member

    Joined:
    Jul 13, 2004
    Messages:
    4,680
    Likes Received:
    376
    I assumed you checked to make sure the pedals were tight?

    EDIT: I did a internet search for your particlar problem,with that particular BB, and what you did seemed to be the correct thing to do. However I found a lot of complaints about noise and durability from your particular FSA model, and they weren't able to fix the noise without getting a new and different BB. Here's one of the many sites I found: http://www.roadbikereview.com/cat/drivetrain/bottom-brackets/fsa/PRD_335456_2479crx.aspx
     
Loading...
Loading...