Hub not turning smoothly

Discussion in 'Cycling Equipment' started by Peter Kellner, Mar 26, 2003.

Thread Status:
Not open for further replies.
  1. I've noticed that on my Rolf Vector Pro hubs that both the front and back do not turn smoothly when
    I simply move the axle back and forth with the wheels out of the bike. When I compare this to other
    hubs (including my older Rolf Vector Comp's) they do not move nearly as smoothly. It's not crunchy
    or anything, but it does take some pressure to move axle around compared to the other ones.

    My questions is:

    1. Is this normal and am I being a perfectionist thinking that the axle should be so smooth?

    2. Will this effect the lifetime of the hub?

    3. What are this issues I should be concerned with.

    Thanks
     
    Tags:


  2. Slight friction is correct. See Jobst Brandt's FAQ about this.
     
  3. peter-<< I've noticed that on my Rolf Vector Pro hubs that both the front and back do not turn
    smoothly when I simply move the axle back and forth with the wheels out of the bike.

    Lots of cart bearings with the rubber seals will make for a sluggish rotation. Doesn't really mean
    anything when riding...can take the hubs apart, remove the seals, add grease, replace the seals...or
    just ride-

    Peter Chisholm Vecchio's Bicicletteria 1833 Pearl St. Boulder, CO, 80302
    (303)440-3535 http://www.vecchios.com "Ruote convenzionali costruite eccezionalmente bene"
     
Loading...
Thread Status:
Not open for further replies.
Loading...