Look CX6 Pedal Squeek - Help!



Nick-NH

New Member
Sep 25, 2003
43
0
0
I very recently invested in a new pair of Look CX6 carbon pedals. They've developed an annoying squeek. Definitely not the bearings but more in the interface between the cleat and the pedal. Up, down, side to side, it's driving me nuts. My (reds) cleats are practically new. Has anyone else had this experience and have a potential remedy? Thanks in advance!
 

Aztec

New Member
Jul 8, 2003
835
0
0
Oddly, my CX6s are the only Look-style pedals I've had that have NOT squeaked. I used some chain lube, like Pro Link or DuMond (maybe it's DeMond). Usually works. Just clean up and very lightly lube the surface. Works on mine for weeks/months... until it rains.

New cleats also fixed it once for me.
 

vcriscenzo

New Member
Jul 15, 2004
1
0
0
Nick-NH said:
I very recently invested in a new pair of Look CX6 carbon pedals. They've developed an annoying squeek. Definitely not the bearings but more in the interface between the cleat and the pedal. Up, down, side to side, it's driving me nuts. My (reds) cleats are practically new. Has anyone else had this experience and have a potential remedy? Thanks in advance!
Sometime this month, the US importer of Look will start shipping a new Bi-material red cleat that will eliminate the squeak. You can tell which ones are new by a white material that is on the cleat at the interfaces with the pedal. Stores may still have the old ones in stock and may need to special order the new ones for you.