Problems with wheels on computrainer

Discussion in 'Cycling Equipment' started by bgoetz, Dec 7, 2012.

  1. bgoetz

    bgoetz Member

    Joined:
    Nov 25, 2010
    Messages:
    816
    Likes Received:
    20
    I am not sure what I could be doing wrong, but I seem to continuously have issues with bearings loosening up after using them on the computrainer. It isn't just one wheelset either, my powertap will now make wheelset number 3 and it is cartridge bearings. I am not tightening it down too much infact the bike actually has a little play in the stand, also the wheel slips on ocassion if I am on a steep grade and apply load, so I don't know what is going on. Any thoughts?
     
    Tags:


  2. vspa

    vspa Active Member

    Joined:
    Jan 11, 2009
    Messages:
    2,203
    Likes Received:
    39
    the clamping mechanism is a bit tricky in my trainer also, every now and then the skewer gets stuck on it, but not to the point of loosening the bearings, well mines are sealed so that might be the reason i don't get trouble there,
     
  3. bgoetz

    bgoetz Member

    Joined:
    Nov 25, 2010
    Messages:
    816
    Likes Received:
    20
    Stuck on it? Could you provide more detail so I could look into this?
     
  4. vspa

    vspa Active Member

    Joined:
    Jan 11, 2009
    Messages:
    2,203
    Likes Received:
    39
    as i lose the clamp to release the wheel, sometimes the skewer head sticks to the clamp, losening the skewer to the wheel hub in its turn, maybe you get a similar problem that makes the hub locknut turn, losening the hub bearings ?
     
Loading...
Loading...