Real Bad Ergomo Pro Problem



JTE83

Member
Jan 28, 2004
1,390
18
0
I think my ergomo head unit is toast. It has ride data that can't be downloaded. I click on the download and it downloads all the records, but when it finishes it says, "There was no data for ErgoRacer to download." So I tried reinstalling the software on another drive [I use 3 different drives on my laptop] and it still gave the same problem download. Pressing the Reset button on the HU didn't work either!

Is this a common warranty problem? Where do I get warranty service? Anyone had this same problem and how was it solved? The main USA distributor dropped Ergome back in November?
 
Ergomo has now ignored 3 emails from me, very poor support! Maybe you people shouldn't buy ergomos anymore!
 
JTE83 said:
Ergomo has now ignored 3 emails from me, very poor support! Maybe you people shouldn't buy ergomos anymore!
I have had the opposite experience. I called the number (1-888-238-3599) at this link:
http://www.fitmultisports.org/ and was able to immediately get help with my problem.

I had a follow up issue today and left a voice mail and within the hour had a return call which satisfactorily resolved that issue.

Scott Simpson
 
my Ergomo Pro took a dump about 3 months ago, and my LBS still has not been able to get me a replacement unit. I spent about $1,600 for the unit and it was about 9 months old when it died.

I am a very dissatisfied customer ! in spite of liking some of the features of the power meter, the service I have received makes me give it a huge thumbs down.
 
pascalhayes said:
I have had the opposite experience. I called the number (1-888-238-3599) at this link:
http://www.fitmultisports.org/ and was able to immediately get help with my problem.

I had a follow up issue today and left a voice mail and within the hour had a return call which satisfactorily resolved that issue.

Scott Simpson

I think Fitmultisports only support ergomos you buy from them? I didn't buy from them and I have to use a general ergomo distributor or ergomo themselves!
 
tmctguer said:
my Ergomo Pro took a dump about 3 months ago, and my LBS still has not been able to get me a replacement unit. I spent about $1,600 for the unit and it was about 9 months old when it died.

I am a very dissatisfied customer ! in spite of liking some of the features of the power meter, the service I have received makes me give it a huge thumbs down.

Funny, my unit was 9 months old too when it died. I'm not gonna buy another $600 computer. I expect to pay ergomo $120 most to fix it!

Did you try contacting ergomo [Germany] themselves too?
 
JTE83 said:
I think Fitmultisports only support ergomos you buy from them? I didn't buy from them and I have to use a general ergomo distributor or ergomo themselves!
Interesting; the unit I bought was not from them nor from Gita when they were the representative US side. But both Gita and now Fitmultisports have been very, very helpful in dealing with my problems.

Scott Simpson
 
earlier this week, I sent letters to the president of Ergomo, the president of GITA (the old US distributor), the director of operations of MultiFit, and my local bike shop outlining my frustration with the service i have received.

I hope to hear from one of them who can hopefully find the bottom bracket that was sent in for repair, fix it, and not take me to the cleaners in the meantime. I'm into the Ergomo for $1,600 and it is lost somewhere between my LBS, GITA, MulitiFit, and Ergomo.

for this reason, I would strongly recommend a Powertap, SRM or even a Polar (yes, I owned two with good results) before I would suggest an Ergomo.
 
earlier today, I received a response directly from Ergomo in Germany. They do not have my bottom bracket in Germany, but will ask MultiFit to try to locate it. they committed to resolving the situation for me. I hope I have good news to report in the coming weeks.
 
JTE83 said:
I think Fitmultisports only support ergomos you buy from them? I didn't buy from them and I have to use a general ergomo distributor or ergomo themselves!
Well where did you buy the Ergomo and have you tried to contact them directly?

If your PC breaks down, would you call Dell, HP etc, who manufactured the PC?
 
koger said:
Well where did you buy the Ergomo and have you tried to contact them directly?

If your PC breaks down, would you call Dell, HP etc, who manufactured the PC?

I bought it from Brone's Bikes in Wisconsin. They initially bought it for themselves to use with a Pulsion crank but it didn't fit. So they "sold" it to me through ebay and said they would support it for warranty. Then later they said they couldn't help me, but they probably would confirm I bought it from them.

I bought my laptop from Dell and I only contact and get great quick service through Dell. About 6 repairs so far!
 
this week, I have heard from Ergomo Germany via email twice, my LBS once by phone, GITA via email, and Ergomo US by phone. so my letters found their way to the right people.

GITA claims that my bottom bracket was not sent to them. GITA said that about the time of my repair, Ergomo had stopped sending them spare parts to perform repairs. THis must have been about the time GITA and Ergomo began to part ways. GITA believes my unit was probably shipped directly to Germany from my LBS.

I vaguely recall my LBS telling me that they could not get the unit repaired via GITA. I vaguely recall them telling me it would be shipped to Germany. Honestly, it was so long ago (about 6 - 7 months) that the memory is pretty hazy.

Ergomo Germany cannot locate my bottom bracket at the factory. They are working with Ergomo US to have a brand new unit federal expressed to my LBS. once it comes in, my LBS should call me to schedule the re-installation.

So far, so good. I really appreciate finally getting some traction on this problem. as I've said before, there are some features I really liked about the Ergomo (large display, % gradient, user programmable display, etc.). I hope the new unit will be problem free.

by the way, I just bought a Garmin Edge 705 today for my 2nd bike. it looks pretty cool (GPS, altimeter, % gradient, programmable screens, etc.). i will still use my PowerTap on my second bike and use the Edge as my 2nd unit for navigation telemetry. it will communicate wirelessly with some power units, but i don't believe the wired Powertap, nor the heart rate straps are compatible.

oh well.............another new toy !
 
as i said in an earlier post, still no resolution to my complaint. turns out my LBS has not received a new Ergomo sensor unit from the US distributor. this is 3 weeks after being promised that a new unit would be fedex'd to them. I wrote another letter to my LBS, Ergomo, and their US distributor asking for resolution.
 
I bought on of these from Cyclepowermeters.com and the head unit died after about 9 months, looks like the batteries were fried. The service I received from these guys was A1. I phoned them to tell them there was a problem, posted the unit off to them and received a replacement 2 days later. In fairness I wouldn't buy another Ergomo, but I'd definitely use this supplier again for their great service.
 
pascalhayes said:
I have had the opposite experience. I called the number (1-888-238-3599) at this link:
http://www.fitmultisports.org/ and was able to immediately get help with my problem.

I had a follow up issue today and left a voice mail and within the hour had a return call which satisfactorily resolved that issue.

Scott Simpson

Ok, I gave these guys a call. Told them my problem about no data download and the first person to answer said he'd switch me to service, next person who answers says they're only an answering service and that they'd take my number and name and would call me back. I gave them my work number and they did not call me all day and there's no voicemail. They claim they're the US Distributor for ergomo, and I beleive they just brushed me off today. I'll try calling again tomorrow, but if they really brush me off, and if ergomo everywhere does not give support, ergomo needs to go down. We need to spam every bike forum, bike news website, bike board, etc - that ergomo is just no good and that people shouldn't buy them. Getting burned $1650 then $700 for a computer sucks!
 
i called the MultiFit offices and spoke to their Director of Operations, Jason Goldberg. on my second call (my first ended in being disconnected shortly after beginning to speak), Mr. Goldberg seemed to want to help. But so far, my LBS has no Ergomo bottom bracket.

Ergomo Germany should recieve my follow up letter tomorrow. MultiFit received the email on Monday. we'll see if the second round of letters yields any action.

i am contemplating taking my LBS to Small Claims court and suing them for my costs. after all, they are the ones who last had possession of my Ergomo unit. I believe I can convince a judge that in the absence of remedy by Ergomo, my LBS owes me a replacement meter since they took possession of it from me. I hate to see it come down to this, but i refuse to walk away from $1,600 and not even have the broken pieces to show for it.

I agree that more cyclists need to hear the stories of poor customer service from Ergomo. these units cost way too much money to be screwed around like this.
 
here is the latest on my Ergomo saga. After hearing nothing after writing a second letter, I sent an email to all of the parties who were copied by my snail mail letters. The US distributor replied with a copy of the Federal Express tracking number which showed that Ergomo HAD shipped the bottom bracket to my local bike shop.

I called them with this information, and apparently there was a communications problem between my LBS & I. Once they confirmed that they had the unit, I dropped the bike off to have it installed.

in the meantime, I've misplaced the freaking computer somewhere (its been sitting idle for 9 months) and i'm tearing my house apart looking for it !

so, i am close to getting this resolved. And Ergomo US did what they committed to doing -- shipping me a replacement bottom bracket after my first letter arrived.