Rear brake help

Discussion in 'Cycling Equipment' started by kordon, Jul 28, 2007.

  1. kordon

    kordon New Member

    Joined:
    Jul 23, 2007
    Messages:
    10
    Likes Received:
    0
    Just had LBS put on new Mavic Open Sport rims yesterday, test ride was fine. Today rear brake won't grab. The adjustment is fine and front grabs perfectly. Any ideas?
     
    Tags:


  2. John M

    John M New Member

    Joined:
    Jun 21, 2005
    Messages:
    1,404
    Likes Received:
    0
    Probably some grease or oil on the rims, brake shoes or both. Clean both with some degreaser and see if it is better.
     
  3. kordon

    kordon New Member

    Joined:
    Jul 23, 2007
    Messages:
    10
    Likes Received:
    0
    Thats what I thought so I cleaned the rim and the pads, lightly sanded the pads and cleaned the rim with some light steel wool just to make sure, no go. The caliper is closing properly but I can easily pull the rim through the brake. The front is fine.
     
  4. alienator

    alienator Well-Known Member

    Joined:
    Jun 10, 2004
    Messages:
    12,596
    Likes Received:
    160
    Check to see if the brake quick release is engaged or not. Then check the brake cable tension.
     
  5. kordon

    kordon New Member

    Joined:
    Jul 23, 2007
    Messages:
    10
    Likes Received:
    0
    Both are fine.
     
  6. hd reynolds

    hd reynolds New Member

    Joined:
    Nov 15, 2005
    Messages:
    813
    Likes Received:
    0
    Borrow a friends caliper and see if that works. If it does then its time to replace the old one.
     
Loading...
Loading...