Shimano STI Shifter problem

Discussion in 'Cycling Equipment' started by June-Seek Choi, Jun 26, 2003.

Thread Status:
Not open for further replies.
  1. Hi all,

    I have a bike with shimano RX100 parts. The problem is with the left STI shifter. It works well when
    it goes up (to the bigger sproket) but then when it goes down it doesn't catch (meaning that my
    thumb feels like pushing without clicking). If shifts fine either way when the bike is on the repair
    stand. So it seems that the problem only occurs when the bike is on the ground. Is there some sorts
    of adjustment I can do to solve this problem? If you had similar problem and have a good idea about
    what to do (including replacing it), let me know. THanks for reading this.

    June
     
    Tags:


  2. I recently began noticing this on my RSX "brifters" (Brake/shifters, or STI).

    I found that if, when I upshift, I push the lever all the way until it reaches it's mechanical stop,
    it will click when I go to downshift.

    This is a recent occurrence, though. I've had these levers for at least five years now, and this
    didn't start happening until recently. Never having done an autopsy on these mechanisms, I can only
    assume it's due to wear.

    May you have the wind at your back. And a really low gear for the hills! Chris

    Chris'Z Corner "The Website for the Common Bicyclist": http://www.geocities.com/czcorner
     
Loading...
Thread Status:
Not open for further replies.
Loading...