Squeaky front hub - Mavic Ksyrium

Discussion in 'Cycling Equipment' started by DaddyShortLegs, Jul 13, 2007.

  1. DaddyShortLegs

    DaddyShortLegs New Member

    Joined:
    Jul 13, 2007
    Messages:
    1
    Likes Received:
    0
    Hi there,

    Last night, after cleaning my bike, I noticed my front hub making a squeaky noise when the wheel is rotating.

    The wheel is a Mavic Ksyrium SSL (from a few years ago).

    Would this be a bearing going or something? Is it a simple maintenance thing, or could something more serious the issue?

    Cheers,

    DSL
     
    Tags:


  2. WIGGUM1

    WIGGUM1 New Member

    Joined:
    Jun 7, 2007
    Messages:
    131
    Likes Received:
    0
    Lube it up!
     
  3. Retro Grouch

    Retro Grouch New Member

    Joined:
    Dec 29, 2005
    Messages:
    584
    Likes Received:
    0
    Oftentimes squeeky hubs are due to a dry axle seal. Put the tiniest dot of silicon lube that you can manage where the axle exits the hub and see what happens.
     
  4. hd reynolds

    hd reynolds New Member

    Joined:
    Nov 15, 2005
    Messages:
    813
    Likes Received:
    0
    Could be overtightened skewers. Mavic recommends that the skewers be tightend lightly when you're able to close it with just a finger. Over-doing it could result in squeaking specially with the rear wheel.
     
  5. EZ Gruv

    EZ Gruv New Member

    Joined:
    Jun 17, 2007
    Messages:
    1
    Likes Received:
    0
    This happens to me sometimes. Just put a dab of lube on the axle seal.
     
Loading...
Loading...